Anybody else running an MSD ignition?


#1

Ive got an MSD 6AL and a Blaster 2 coil on my car and it worked fine till last night. I started the car for a minute and it just died like someone shut the ignition switch off. It still has full power but makes no spark. I had the battery charger hooked up at the time. Is it possible that I might have fried the unit by having the charger hooked up?? :dunno


#2

Anybody?? :dunno


#3

Do you have power to everything? I’ve never heard of a battery charger shorting one out like that.


#4

Yeah, I double then triple checked all my power connections and I have a constant 13.6 volts on the constant wire, I have a steady 12.8 volts on the ignition side only when I flip the switch and i have a good ground (straight to the head). I also checked the connections to the distributor and the coil and they are also good. I am thinking it is a possibility that I blew the ignition module in the distributor. I am going to have it checked when I get a chance to pull it. I forgot to mention that I am still running the Ford distributor. Im saving for the MSD Pro Billet.


#5

[quote=Bossman351]Yeah, I double then triple checked all my power connections and I have a constant 13.6 volts on the constant wire, I have a steady 12.8 volts on the ignition side only when I flip the switch and i have a good ground (straight to the head). I also checked the connections to the distributor and the coil and they are also good. I am thinking it is a possibility that I blew the ignition module in the distributor. I am going to have it checked when I get a chance to pull it. I forgot to mention that I am still running the Ford distributor. Im saving for the MSD Pro Billet.[/quote]i ran mine with charger hooked up …you might have i bad pick up in dist,


#6

DING DING DING DING!!! WE HAVE A WINNER!!! :lol Hey nos/man, not only was the pickup bad, but when i pulled the distributor and took it apart, all of the weights and springs and retainers for the timing advance just fell right out in my hand. :wtf I put another distributor in it (out of one of mah derby cars :lol ) then hooked the MSD back up and VOILA we have ignition!!! She sounds a lot better now too. I was having trouble setting the timing with everything broken but now she runs sweet. Future mod: MSD Pro Billit Distributor RTR :woot